Can’t install ia32-libs and ia32-libs-multiarch: how to fix it

Posted: October 26, 2012 in Linux

When tried to install teamviewer on my Ubuntu 12.04 64bit, the system complaining about unmet dependencies and can not install ia32-libs, but when I tried to install ia32-libs, here’s what I got:

rumy@cbug-nest:~$ sudo apt-get install ia32-libs
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ia32-libs : Depends: ia32-libs-multiarch
E: Unable to correct problems, you have held broken packages.

An attemp to install ia32-libs-multiarch failed too

After some dig on internet I found the solution:

(1) Edit /etc/apt/preferences

rumy@cbug-nest~$ sudo pico /etc/apt/preferences

(2) Add this 3 line code

Package: *       
Pin: release a=precise*
Pin-Priority: 2012

(3) Do dist-upgrade

rumy@cbug-nest~$ sudo apt-get dist-upgrade

It will ask you to downgrade some package, just answer (Y)es

(4) Install ia32-libs-multiarch and/or ia32-libs

rumy@cbug-nest~$ sudo apt-get install ia32-libs-multiarch


(5) Delete /etc/apt/preferences, after you finished updating

rumy@cbug-nest~$ rm /etc/apt/preferences

Other solution that work too:

sudo apt-get install librtmp0/precise
About these ads
Comments
  1. Glutier says:

    OH THANK YOU SO MUCH! You just saved me from a full re-install…
    I linked your page on Reddit:
    https://www.reddit.com/r/linuxquestions/comments/10u9ic/wine_wants_to_uninstall_compiz_unity_and_a_bunch/

  2. NTT says:

    i am trying.
    hope that work!

  3. RAZOR says:

    It works for me, thanks a lot :)

  4. Alex says:

    Hi, thanks a million because I have been able to fix mi problem with ia32-libs and install Skype… But now I have an undesired consequence with grub-efi-amd64. I have discribed it here: http://askubuntu.com/a/284973/151586

    Any idea? Thanks in advance.

    • rumytaulu says:

      I am not sure, because I didn’t have that kind of error when I solved this problem, it could be (U)EFI related (I didn’t have EFI BIOS on the machine I fixed), or just dependency problem.
      Did you alredy tried to fix the dependency problem? like ‘dpkg –configure -a’ ?

      And this error: line 684: grub-install: command not found
      Did you have grub-install on your system? what ‘whereis grub-install’ give you?

      • Alex says:

        Hi rumytaulu, thanks for replying!

        I already tried ‘dpkg –configure -a’, actually is one of the first things I tried and I get this:

        Setting up grub-efi-amd64 (1.99-21ubuntu3.9) …
        /var/lib/dpkg/info/grub-efi-amd64.postinst: line 684: grub-install: command not found
        dpkg: error processing grub-efi-amd64 (–configure):
        subprocess installed post-installation script returned error exit status 127
        dpkg: dependency problems prevent configuration of grub-efi-amd64-signed:
        grub-efi-amd64-signed depends on grub-efi-amd64 (>= 1.99-21ubuntu3.5); however:
        Package grub-efi-amd64 is not configured yet.
        dpkg: error processing grub-efi-amd64-signed (–configure):
        dependency problems – leaving unconfigured
        Errors were encountered while processing:
        grub-efi-amd64
        grub-efi-amd64-signed

        It is very weird, I just cannot do anything… the only thing I come up is to remove the package but I’m afraid it will crap my booting system. I presume Grub is installed as I boot my computer with Grub. By the way, this is what I get after running ‘whereis grub-install’:

        grub-install:

        Nothing else…

        Thanks.

  5. Tony says:

    HI, I am new to Linux and I do not know how to add 3 line code and save in terminal. do I need to create new document with these 3 codes? what extension of document needs to be.

    thanks in advance
    tony

    • rumytaulu says:

      You don’t need to, too add the 3 line code (number 2), use the command in (number 1) :
      To able to do it, you must first open the Terminal like this:

      (a) Press [Ctrl][Alt][T]

      or you can do it by go to Dash Search (Top Left Icon) and type Terminal and Click Terminal
      and then type (in Terminal prompt) :

      (b) sudo pico /etc/apt/preferences

  6. Thx, man! You saved me…
    Just to be correct: In step4 add ‘install’ to the apt-get command!

  7. […] searching for solutions in many places I found a solution at TRAVELLING LINUX . The steps for your reference are quoted […]

  8. Usman says:

    Finally some useful information.
    Thanks mate. Great job!

  9. solvation! says:

    This got me solved in the end, after a lot of searching!
    Thanks a ton

  10. Gustavo says:

    Gracias, me sirvio en Elementary OS Luna

  11. Calum says:

    OMG it worked! :D :D :D :D! Thanks a lot! Elementary OS Luna too.

  12. Ralph says:

    I can only repeat all the grateful thanks already said before.
    Thank You so much!
    Ralph from Germany

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s